Visual Studio 2010 Macros vsaenv cannot find one or more components error

This week has been nothing but hassles after upgrading to Visual Studio 2010 Professional. 

After a few days running VS2010, I was happy with the installation so I decided to uninstall Visual Studio 2008 from my computer.  The uninstall went fine and I even bounced my PC just to be on the safe side.

At first Studio 2010 seemed completely unaffected by the uninstall of VS2008, but boy was I wrong.  As soon as I tried to fire off a recorded macro VS2010 just sits there like it’s going to hang.  Eventually I noticed a background popup box in the taskbar.  I switched to it and saw that VS2010 was complaining “cannot find one or more components…” blah blah blah.

Closing the popup had a 50/50 chance of completely blowing up the VS2010 IDE.  Joy.

I even tried doing a Repair from the installation setup.  No luck.

After researching this morning, I found the cause.  I have copied both it and the solution below.  In my situation, this resolved it perfectly and I didn’t even have to reboot.

2.1.7 On computers on which Visual Studio 2008 or SQL Server 2008 is installed and Visual Studio 2010 has been uninstalled and then reinstalled, using the Visual Studio Macros IDE may cause Visual Studio to crash

Uninstalling Visual Studio 2010 also removes the Visual Studio Macro Tools package. If the computer also has Visual Studio 2008 or SQL Server 2008, then reinstalling Visual Studio 2010 does not reinstall the Visual Studio Macro Tools package. This causes an error when the Macros IDE is started, and Visual Studio crashes if you try to recreate the MyMacros.vsmacros project.

To resolve this issue:

  1. Delete the following file:
    1. On a 64-bit operating system: "%ProgramFiles(x86)%\Microsoft Visual Studio 9.0\Common7\IDE\1033\Microsoft.VSDesignerUI.dll"
    2. On a 32-bit operating system: "%ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\1033\Microsoft.VSDesignerUI.dll
  2. On the Add or Remove programs page, select Uninstall/Change Visual Studio 2010 and then click Next.
  3. Select Add or Remove features.
  4. Clear and then re-select any of the features in the list. This causes the update state to be enabled.
  5. Finish the Setup wizard. Visual Studio Macro Tools should be installed.

3 Replies to “Visual Studio 2010 Macros vsaenv cannot find one or more components error”

Leave a Reply

Your email address will not be published. Required fields are marked *